[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Momonga-users.ja:00544] Re: rpm のrebuildオ プション



続報@leonですが、
あいかわらず問題解決には後一歩です。

同じくvineサイトから
gtkimageview-1.3.0-0vl1.src.rpm を入手し rebuile 、
gtkimageview, gtkimageview-devel を無事インストールしました。

以下、ufraw-0.12.1-0vl1.src.rpm の rebuile 結果です。

$ sudo rpmbuild --rebuild ufraw-0.12.1-0vl1.src.rpm 
ufraw-0.12.1-0vl1.src.rpm をインストール中です。
警告: InstallSourcePackage: ヘッダ V3 DSA signature: NOKEY, key ID 53233490
実行中(%prep): /bin/sh -e /var/tmp/rpm-tmp.26550
+ umask 022
+ cd /usr/src/momonga/BUILD
(snap)
ufraw_exiv2.cc: In function ‘int ufraw_exif_from_exiv2(ufraw_data*)’:
ufraw_exiv2.cc:74: error: ‘class Exiv2::ExifData’ has no member named ‘copy’
ufraw_exiv2.cc:84: error: ‘class Exiv2::ExifData’ has no member named ‘copy’
ufraw_exiv2.cc:88: error: ‘class Exiv2::ExifData’ has no member named ‘eraseThumbnail’
ufraw_exiv2.cc:92: error: ‘class Exiv2::ExifData’ has no member named ‘copy’
make[2]: *** [ufraw_exiv2.o] エラー 1
make[2]: ディレクトリ `/usr/src/momonga/BUILD/ufraw-0.12.1' から出ます
make[1]: *** [all-recursive] エラー 1
make[1]: ディレクトリ `/usr/src/momonga/BUILD/ufraw-0.12.1' から出ます
make: *** [all] エラー 2
エラー: /var/tmp/rpm-tmp.1387 の不正な終了ステータス (%build)

RPM ビルドエラー:
    InstallSourcePackage: ヘッダ V3 DSA signature: NOKEY, key ID 53233490
    /var/tmp/rpm-tmp.1387 の不正な終了ステータス (%build)



On Mon, 4 May 2009 23:21:07 +0900
leon <momonga@xxxxxxxxxxxxx> wrote:

> 中井様、早々ありがとうございます。
> 
> 少し進展しましたが、問題解決には後一歩です。
> 
> グラフィックアプリの充実している momonga ですが、
> raw ファイルの編集を GUI で扱える ufraw が無いようでしたので
> (コマンドラインのdcrawはありましたが編集は可能?)
> vineサイトから
> ufraw-0.12.1-0vl1.src.rpm を入手し rebuile を試みました。
> 
> 以下、結果です
> 
> $ sudo rpmbuild --rebuild ufraw-0.12.1-0vl1.src.rpm 
> ufraw-0.12.1-0vl1.src.rpm をインストール中です。
> 警告: InstallSourcePackage: ヘッダ V3 DSA signature: NOKEY, key ID 53233490
> エラー: ビルド依存性の失敗:
> 	gtk2-devel >= 2.6 は ufraw-0.12.1-0vl1.i386 に必要とされています
> 	gimp-devel は ufraw-0.12.1-0vl1.i386 に必要とされています
> 	libexif-devel は ufraw-0.12.1-0vl1.i386 に必要とされています
> 	exiv2-devel は ufraw-0.12.1-0vl1.i386 に必要とされています
> 	lcms-devel は ufraw-0.12.1-0vl1.i386 に必要とされています
> 	gtkimageview-devel >= 1.3.0 は ufraw-0.12.1-0vl1.i386 に必要とされています
> 
> gtk2-devel 〜 lcms-devel までは yum でインストールできましたが、
> 最後の gtkimageview-devel は
> No package gtkimageview available. でした。
> 
> 
> On Mon, 4 May 2009 22:27:26 +0900
> Ichiro Nakai <ichiro@xxxxxxxxxxxxx> wrote:
> 
> > こんばんは。
> > 中井です。
> > 
> > On Mon, 4 May 2009 22:14:12 +0900
> > leon <momonga@xxxxxxxxxxxxx> wrote:
> > 
> > > rpm --rebuild ******.src.rpm
> > > --rebuild: 不明なオプション
> > > 
> > > となります。
> > > 
> > > src.rpm はどのようにインストールすれば良いですか?
> > > 
> > 現在は、rpmbuild コマンドを用います。
> > 
> > rpmbuild --rebuild
> > 
> > でしょうか。
> > 個人的には一度
> > 
> > rpm -ivh ******.src.rpm
> > 
> > で、展開して、中を確認した後
> > 
> > rpmbuild -ba ******.spec
> > 
> > しています。
> > 
> > -- 
> > Ichiro Nakai
> > ichiro@xxxxxxxxxxxxx
> > 

-- 
leon <momonga@xxxxxxxxxxxxx>